Arcades 3D - Foro

Juegos Destacados => Doom, Doom II, Doom 3 => Mensaje iniciado por: REBEL en Agosto 26, 2020, 09:10:57 pm

Título: MIDI soundtrack no suena en mi DOOM
Publicado por: REBEL en Agosto 26, 2020, 09:10:57 pm
Descargué los archivos MIDI's de Doom pero al iniciar el juego no suena, y eso que fui a opciones a ver si era que estaba en "tono bajo", pero no está al máximo y aun así no se escucha. Los SFX se oyen bien, en eso no hay problema.

La configuración la puse bien:
Ni en GUS se me oye, lo mismo que "Native MIDI"
y en "Adlib" se me oye bajo aunque esté alto.

Alguna idea de por qué no se me oye el MIDI nativo?

(https://i.imgur.com/lb81j1r.png)

Título: Re:MIDI soundtrack no suena en mi DOOM
Publicado por: BOT69 en Agosto 26, 2020, 09:22:27 pm
¿Te refieres a archivos MID?
Se supone que lo que tienes ahí puesto es para sustituir MIDIs por MP3/OGG.
Prueba dejando vacío el Native MIDI, es decir, no lo dejes enlazado a nada.
Echale un vistazo a esta sección de la Wikia: https://www.chocolate-doom.org/wiki/index.php/Gameplay_enhancements

El caso de GUS (Gravis UltraSound) necesitas unos PATs como libreria.
Título: Re:MIDI soundtrack no suena en mi DOOM
Publicado por: REBEL en Agosto 27, 2020, 12:19:43 pm
Dejé vacío, no enlacé en midi con nada y sigue igual.
Título: Re:MIDI soundtrack no suena en mi DOOM
Publicado por: BOT69 en Agosto 27, 2020, 06:21:44 pm
OPL (Adlib/Sound Blaster) se escucha porque es emulado por el puerto, GUS necesita de archivos PATs, Native MIDI usa la librería que tenga instalada el sistema operativo.
¿Sabes si tu sistema operativo tiene alguna librería instalada?
¿Usas Windows 10?

Creo que el problema va más por el sistema operativo que por el puerto en sí.

EDIT
Mirando entre los comentarios de GitHub (https://github.com/chocolate-doom/chocolate-doom/issues), hay más personas que tienen problemas con Native MIDI o con el sonido directamente.
Realmente no sé si puedo ofrecer más ayuda respecto a este tema.
Título: Re:MIDI soundtrack no suena en mi DOOM
Publicado por: REBEL en Agosto 28, 2020, 11:01:33 am
Uso Windows 7, y usando en timidity poniendolo en native midi funciona (pero suena horrible, no se si es por el formato pero bien no suena) Lo mismo con GUS.
Yo lo que intentaba era que sonara como era en los 90's.
Título: Re:MIDI soundtrack no suena en mi DOOM
Publicado por: BOT69 en Agosto 28, 2020, 03:27:20 pm
No se puede decir que un MIDI suene como en los 90 porque realmente no había un estandar de librería MIDI.
Cada placa de audio tenía su propia librería basada en su hardware, al final no había forma de que 10 personas con placas diferentes escuchasen la misma música con la misma calidad.
Native MIDI viene a sustituir General MIDI, luego están las opcionales, con Timidity puedes buscar librerías personalizadas y con Digital music pack puedes remplazarlas por MP3/OGG.

No puedo ofrecer mucha ayuda con este tema.
Título: Re:MIDI soundtrack no suena en mi DOOM
Publicado por: REBEL en Agosto 29, 2020, 01:01:38 am
Oki, gracias por la ayuda igualmente ;)
Título: Re:MIDI soundtrack no suena en mi DOOM
Publicado por: Lenin en Septiembre 01, 2020, 10:28:28 pm
Si lo que quieres es que "suene como en los 90", lo más seguro es que usaras un chip clónico de Soundblaster16 con OPL3. Tienes que buscar una fuente de sonidos (soundfont) OPL2 u OPL3, descargarla y decirle al mapeador MIDI de tu sistema operativo que se dirija a ella. Aunque quizá te sorprenda el MIDI se sigue usando a nivel profesional tanto como en los 90, lo que pasa es que los juegos ya no suelen usarlo. Pero como es muy común, todos los sistemas operativos pueden usrlo de fábrica, otra cosa es que no suelan venirte fuentes de instumentos preinstaladas y lo dejen eso a cargo del usuario (y que yo sepa, sólo Win9x las preinstalaba. Desde luego que en Win3.x tenías que tirar de disquette)

Suerte